Ads displayed for guests and not donating members only. Get ad-free by donating. If you have already donated, please read here.
Results 1 to 8 of 8

Thread: ADU on Linux

  1. #1

    ADU on Linux

    Wanted to pop a quick note about getting ADU running on Linux. If you're using PlayOnLinux it is pretty easy and works fairly well in the limited testing I've done. The important part is that you use the same PlayOnLinux virtual drive that is already being used for WoT.

    I wasn't able to get the 'Create a Shortcut from this Virtual Drive' option inside PoL to work, so I just did things the easy way.

    Find your Play On Linux local folder. It should be under ~/.PlayOnLinux. There are two primary locations under here that you'll be dealing with:

    ~/.PlayOnLinux/shortcuts - Stores the shortcut info you see in the PoL window.
    ~/.PlayOnLinux/wineprefix/WorldOfTanks/drive_c/ - The C: drive for the WoT PlayOnLinux 'emulator'

    1. Download ActiveDossierUploader.exe and copy it somewhere onto the WoT C: drive. I put it under Games/World_of_Tanks/ so its easier to find.
    2. Copy the WoT PlayOnLinux shortcut to an ADU shortcut:
    # cp -a ~/.PlayOnLinux/shortcuts/{World\ Of\ Tanks,ADU}
    3. Edit the new ADU file. You only really need to change one line if you put ADU in Games/World_of_Tanks/.

    $ diff World\ Of\ Tanks ADU 
    < POL_Wine WoTLauncher.exe "$@"
    > POL_Wine ActiveDossierUploader.exe "$@"
    ** At this point, the new shortcut would show up in PoL. If not restart PoL and check for syntax errors or something in the file.

    4. Go into the PlayOnLinux Configuration for the WoT installation, then Install Components, and install dotnet40 (I installed dotnet35 first only to get an error that 4.0 is needed... You may end up needing dotnet35 as well)

    5. Click the ADU shortcut in PlayOnLinux and it should be working.

    I did this on Linux Mint 17 x64, PoL 4.2.5, WINE 1.7.22, WoT 9.6, ADU v3.3.0.1. Depending on your setup file paths may be different. Using `find ~ -name wineprefix` should help you locate the folder if you can't find it anywhere, and judicious use of `ls` will get you the rest of the way.

    The Dossier and Battle Results appear to upload automatically when the check interval elapses or I hit the 'Check and Upload' button. I've turned on replay uploads in the config, but they don't seem to be getting picked up automatically. I've tried changing the file path, but still no luck :/ They do work if I hit the 'Upload Replays' button and Shift-select all of them though, so no worries there. Still better than the janky python script I wrote to upload all my replays.

    This same shortcut trick works to get replays working as well... Just use the following line and setup PoL to use the WoTReplay shortcut for .wotreplay files:

    POL_Wine WorldOfTanks.exe "$@"

    This can probably be refined even further by having the ADU.exe file get called automagically by the main WoT shortcut, but I haven't had a chance to play with it anymore.
    Last edited by; 2015-03-05 at 12:39.

  2. #2
    Commander's Avatar
    Join Date
    Jan 2013
    Erlangen, Germany
    Thanks for sharing your experience.

    On a side note, you can use the API to upload files without using ADU:

  3. #3
    I had written up some python scripts after my curl problems (thanks for finding the fix btw), but it was pretty clunky and had to be run manually. In order to get a real working solution I'd have had to tie in inotify and proper checks (basically, rebuild ADU in something more portable than .Net). I'm a sysadmin, so scripts are nothing but writing a program with proper error handling would take me way too long Plus when I did a batch upload of replays I found that sometimes the data would just never populate even though the uploads would return Success. I probably would have worked on it if it hadn't been so easy to get working through PoL though.

    For ROI, I'd have to recommend anyone on PoL at least try this before slapping together something with the API. Judging from the lack of results in a linux search against this site, it doesn't look like there is enough demand for a native linux ADU client either.

    It also looks like a 'Windows restart' through PoL solved my problems with the Replays not being uploaded. ATS and BRR appear to be working for me as well.

  4. #4
    Commander's Avatar
    Join Date
    Jan 2013
    Erlangen, Germany
    There are just a few users with Linux.

    Statistics for Site Usage:
    93.17% Windows
    3.34% Android
    2.02% iOS
    0.83% Macintosh
    0.37% Linux
    0.14% Windows Phone
    0.04% Chrome OS
    0.02% Blackberry

    What kind of OS is Wine reporting? Fake Windows or Linux?

  5. #5
    That's a very good question. I would assume it gets reported as fake windows. If it would help, I can provide the ADU log output when I play tomorrow for cross referencing against server logs.

  6. #6
    I tested it with the POL Shortcut creation with Wine 1.7.48- staging and CSMT enabled and it works fine

  7. #7

  8. #8


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts