Ads displayed for guests and not donating members only. Get ad-free by donating. If you have already donated, please read here.
Results 1 to 12 of 12

Thread: Latest version of BRR causes other mods to fail.

  1. #1

    Latest version of BRR causes other mods to fail.

    I noticed this morning that ATS and BRR were updated recently, and the ADU client (v3.4.0.4) installed the new versions (v1.0.25) automatically.

    However, when I launched the game, I immediately noticed problems with other mods installed in ..\res_mods\\scripts\client\mods.

    I use a mod, WTP_SkipIntro.pyc, from WotTweakerPlus that removes the flaming logo on game launch. After the new versions of ATS/BRR were in, the flaming logo showed up. Seeing it on game load is an immediate indication that Something Went Wrong™. When I got into a match, other mods in ..\scripts\client\mods were nonfunctional as well.

    When I deactivate ATS/BRR from the ADU client and relaunch the game, everything is as it should be. Since I regularly make backups of the scripts directory, I popped in the older version of ATS/BRR and loaded the game; it worked perfectly (though ADU did not like it).

    I have run into this exact problem in the past: after 0.9.8 released, when I installed a script that worked well with 0.9.7 but was apparently incompatible with 9.8 and caused all other scripts to fail. Removing that script restored everything to working order as well. This is why I make backups of the scripts folder, last time just a few days ago on 21 June.

    I noticed that the new ATS.pyc was the same size as the old version, so I enabled that and left BRR off, and the game worked fine. Alternatively, with ATS turned off and BRR turned on, the other mods were broken. So the issue is definitely with BRR.

    Is it possible to force ADU to use the older version of BRR until this issue can be examined?

    Edit: After examining the python.log, the game apparently loads all .pyc files in ../scripts/client/mods in alphabetical order; once it gets to BRR no other mods are loaded. With BRR removed the game finishes initializing all mods.
    Last edited by; 2015-06-23 at 16:48.

  2. #2
    same problem here

  3. #3
    Quote Originally Posted by View Post
    same problem here
    I've been in touch with Phalynx about this. Can you post your python.log file which is located in your game installation directory, e.g. C:\Games\World_of_Tanks\python.log? Every bit of data helps.

  4. #4
    Commander's Avatar
    Join Date
    Jan 2013
    Erlangen, Germany
    Theurge, thanks for your analysis and your logfile Seems BRR is stopping WoT from loading further mods.

    Does it help if you rename BRR to ZZZ.pyc? As a quick workaround this should help. I don't have WoT so I cannot verify that.

  5. #5
    Commander's Avatar
    Join Date
    Jan 2013
    Erlangen, Germany
    For anyone interested, the full source code of BRR is stored here:

  6. #6
    same error, have this in log:

    INFO: [SL_PRO ERROR] Exception in (<type 'exceptions.TypeError'>, TypeError("cannot concatenate 'str' and 'tuple' objects",), <traceback object at 0x15CAF9E0>)

    be aware i am still using 0.9.8 mod folder, changed through paths.xml - but i doubt it has somethign to do with the error

    renaming to anything does not help... actually, other mods will load as WoT is loading scripts alphabetically. mod has to be disabled

  7. #7
    I have a different problem. That the BRR is installed but it is not picking up battle results unless I open them in the client.

  8. #8
    Quote Originally Posted by View Post
    Does it help if you rename BRR to ZZZ.pyc?
    I was going to ask you about that in my email once I realized they're loaded alphabetically, but I wasn't sure how ADU communicates with the ATS/BRR mods and if renaming the file would break it. In the end I just disabled BRR entirely yesterday.

    But today prior to starting the game, I enabled BRR through ADU, then renamed it to ZZZ.pyc as suggested, then launched the game and all mods loaded normally. I played a quick game and all seems in order, but I'm not sure if BRR is gathering the results. I won't know for sure until I play a few more games.

    Edit: If items listed as "BattleResult" (filename: bunch-of-numbers.dat) in ADU are coming from BRR, then it works while BRR is renamed ZZZ.pyc.
    Last edited by; 2015-06-24 at 19:07.

  9. #9
    well, as i wrote, renaming does not matter. if you use smarter that standard loader, you will see that the python script (no matter the name) was not loaded and there is an error

    for me, ADU is also working somehow, but i doubt all results will be catched without BRR. maybe battles that end when you are in another battle wont be catched? cause ADU get only those results you see as relust screen after battle

  10. #10
    Commander's Avatar
    Join Date
    Jan 2013
    Erlangen, Germany
    Please try v1.0.26:

    ADU will also recognize this new version.

    BRR retrieves only Battles where the player does not review the Battle Result. All other Battle Results are detected by ADU without any mods.

  11. #11
    Quote Originally Posted by View Post
    well, as i wrote, renaming does not matter.
    Renaming it worked fine for me, as verified by python.log.

    INFO: Load mods: ATS
    INFO: Load mods: autoaim_indicator
    INFO: 2015-02-24
    INFO: config file: ./res_mods/

    (all mods loading, etc...)

    INFO: Load mods: stat
    INFO: Session Statistics by tratatank modified by _Eddy_, _Jeso_, soloviyko [YasenKrasen 9.8.0]
    INFO: Load mods: TeamHPPools_98
    INFO: Load mods: WTP_SkipIntro
    INFO: Load mods: zzz
    More importantly, with the file renamed to ZZZ.pyc, all the mods worked in the game, and battle results were being pulled correctly.

    Previously, while the mod was named BRR.pyc, once the game got to loading BRR, further mods would not load and wouldn't appear in python.log at all, and wouldn't work in game.

    if you use smarter that standard loader
    I don't know what this means.

    In any case it's a moot point; the updated 1.0.26 version loads fine:

    INFO: Load mods: battle_assistant
    INFO: Battle Assistant: v1.3.1
    INFO: Load mods: BRR
    NOTICE: [NOTE] (, 207): BRR loaded
    INFO: Load mods: Circle15
    INFO: Load mods: DamageLog
    Thanks for taking care of the issue Phalynx, and since I gather the mod was written by locastan please pass along my thanks to him as well!

    I will try to do a better job of paying attention to these forums, but in the future if you require assistance in testing anything, feel free to send me an email and I'd be more than happy to help.

  12. #12
    Commander's Avatar
    Join Date
    Jan 2013
    Erlangen, Germany
    Thanks for testing!

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts